Задать вопрос
10 сентября, 20:19

Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2) минимальное значение; 3) среднее арифметическое значение.

+2
Ответы (1)
  1. 10 сентября, 21:35
    0
    program n1;

    const n=10;

    var

    mas:array[1 ... n] of integer;

    i:integer;

    max, min, sum:integer;

    ar:real;

    begin

    for i:=1 to n do

    begin

    mas[i]: = random (20) - 10;

    write (mas[i],' ') ;

    writeln

    end;

    max:=1;

    for i:=2 to n do

    if mas[i]>mas[max] then

    max:=i;

    writeln;

    writeln ('Максимаьное значение a[', max,'] = ', mas[max]) ;

    min:=1;

    for i:=2 to n do

    if mas[i]
    min:=i;

    writeln;

    writeln (Минимальное значение a[', min,'] = ', mas[min]) ;

    for i:=1 to n do

    sum:=sum+mas[i];

    ar:=sum/n;

    writeln;

    writeln ('Среднее арифметическое = ', ar) ;

    end.

    {Немного нерационально но работает=) }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2) минимальное значение; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, заполняющую массив из 45 элементов случайными числами от 0 до 34, выводящую полученный массив на экран, прозврдящую поиск элементов, делящихся на 3, подсчитывающую их количество (с выводом на экран) и считающая среднее
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
В pascal. 1) Заполните массив случайными числами из интервала [-50; 50), вывести на экран, посчитать сумму отрицательных элементов. 2) Ввести одномерный массив, вывести его на экран, найти максимальный элемент и его порядковый номер.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)