Задать вопрос
2 декабря, 22:22

Помогите написать программу в Паскале.

Дан массив размера N.

1. Найти количество участков К, на которых его элементы монотонно возрастают.

+5
Ответы (1)
  1. 3 декабря, 02:10
    0
    Const n=20;

    var a:array[1 ... n] of integer;

    i, k, m:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (51) ;

    write (a[i]:3) ;

    end;

    writeln;

    k:=0; m:=0;

    for i:=1 to n-1 do

    begin

    if a[i+1]>a[i] then begin m:=m+1; end

    else begin if m>0 then k:=k+1; m:=0; end;

    end;

    if m>0 then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Массив A:

    7 30 22 0 17 4 2 32 39 26 23 41 1 38 47 21 38 31 43 7

    k = 7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Паскале. Дан массив размера N. 1. Найти количество участков К, на которых его элементы монотонно возрастают. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)