Задать вопрос
28 августа, 02:12

1. Дано натуральное число.

а) найти произведение цифр числа.

б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры).

2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5.

3. Из данного числа удалить все цифры А (А вводится с клавиатуры).

В Free Pascal.

+1
Ответы (1)
  1. 28 августа, 03:47
    0
    Uses Crt;

    Var

    A, B:integer;

    P:real;

    C:boolean;

    Begin

    ClrScr;

    Write ('Введите натуральное число: ') ; ReadLn (B) ;

    Write ('A = ') ; ReadLn (A) ;

    P:=1;

    C:=false;

    B:=Abs (B) ;

    While B>0 do

    Begin

    P:=P * (B mod 10) ;

    if B mod 10 = A then C:=true;

    B:=B div 10

    End;

    WriteLn ('P = ', P) ;

    if C then WriteLn ('Не верно')

    else WriteLn ('Верно') ;

    ReadLn

    End.

    uses Crt;

    Var

    A:integer;

    Begin

    ClrScr;

    For A: = 100 to 999 do

    if ((A+1) mod 2 = 0) and ((A+2) mod 3 = 0) and ((A+3) mod 4 = 0) and ((A+4) mod 5 = 0) then Write (A,' ') ;

    ReadLn;

    End.

    uses Crt;

    Var

    A, B, C:integer;

    Begin

    ClrScr;

    Write ('Введите натуральное число: ') ; ReadLn (B) ;

    Write ('A = ') ; ReadLn (A) ;

    C:=0;

    While B0 do

    Begin

    if B mod 10 A then C:=C*10+B mod 10;

    B:=B div 10;

    End;

    While C0 do

    Begin

    B:=B*10+C mod 10;

    C:=C div 10

    End;

    WriteLn (B) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано натуральное число. а) найти произведение цифр числа. б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Найти все трёхзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Паскаль 1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число делится на В (В вводится с клавиатуры). 2. Квадраты некоторых трехзначных чисел оканчиваются тремя цифрами, которые как раз и составляют исходные числа.
Ответы (1)