Задать вопрос
11 марта, 01:53

1. Заменить отрицательный эллемент нулем.

2. Дан массив целых чисел. Найти сумму элементов массива, больших данного числа А (А вводить с клавиатуры).

3. Определить есть ли 2 пары соседних элементов с одинаковыми знаками. Паскаль.

+4
Ответы (1)
  1. 11 марта, 02:34
    0
    2.

    var a, n, i, sum, x:Integer;

    begin

    readln (a, n) ;

    sum:=0;

    for i:=1 to n do

    begin

    read (x) ;

    if (x>a)

    then

    sum:=sum+x;

    end;

    writeln ('Сумма: ', x) ;

    end.

    3.

    var

    begin

    readln (n) ;

    pairs:=0;

    if (n>0)

    then

    read (x) ;

    last:=x;

    for i:=2 to n do

    begin

    read (x) ;

    if (x>-1 and last>-1 or x<0 and last<0)

    then

    inc (pairs) ;

    last:=x;

    end;

    if (pairs>1)

    then

    writeln ('Yes.') ;

    else

    writeln ('No.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Заменить отрицательный эллемент нулем. 2. Дан массив целых чисел. Найти сумму элементов массива, больших данного числа А (А вводить с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)