Задать вопрос
24 апреля, 02:05

Вводить числа с клавиатуры до тех пор, пока сумма четных из них не совпадёт с суммой нечетных

+1
Ответы (1)
  1. 24 апреля, 03:38
    0
    Var

    A:integer;

    Sc, Sn:real;

    Begin

    Sc:=0;

    Sn:=0;

    Repeat

    Read (A) ;

    if A mod 2 = 0 then Sc:=Sc+A

    else Sn:=Sn+A;

    Until Sc=Sn;

    WriteLn ('S = ', Sc)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводить числа с клавиатуры до тех пор, пока сумма четных из них не совпадёт с суммой нечетных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Вводить с клавиатуры числа до тех пор пока не будет выведено число 100 найти количество четный чисел 2. Ввести с клавиатуры натуральное число. Изменить его левую цифру на "9"
Ответы (1)
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)
Язык Паскаль! 1) Вводить с клавиатуры числа, пока не будут введен 0. Найти количество введенных чисел. 2) Числа задаются случайно в диапазоне от [-10,10] и выводятся на экран. Находится сумма числе, пока число не станет равным 0.
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)