Задать вопрос
26 апреля, 09:51

Напишите программу, которая находит квадрат произведения цифр

введенного числа

+1
Ответы (1)
  1. 26 апреля, 13:20
    0
    Var a, p:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a:=abs (a) ;

    p:=1;

    while a0 do

    begin

    p:=p * (a mod 10) ;

    a:=a div 10;

    end;

    p:=p*p;

    writeln ('p = ', p) ;

    end.

    Пример:

    a = 273

    p = 1764
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая находит квадрат произведения цифр введенного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1. Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. 2. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
Написать программу, которая находит сумму всех цифр введенного с клавиатуры четырехзначного числа
Ответы (1)