Задать вопрос
23 октября, 22:21

Помогите с Паскалем. вычислите p = (n+1) ! (Факториал)

+4
Ответы (1)
  1. 24 октября, 00:53
    0
    Program n1;

    var n: integer;

    function fact (x: integer) : real;

    begin

    if x=0 then fact:=1 else fact:=fact (x-1) * x;

    end;

    begin

    readln (n) ;

    write (fact (n+1)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с Паскалем. вычислите p = (n+1) ! (Факториал) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С помощью repeat S = (x / (факториал) 1) + (х^2 / (факториал) 2) + (х^3 / (факториал) 3) + ... + (х^n / (факториал) n) + 0,0001
Ответы (1)
Каждый из 35 участников олимпиады по программированию владеет Паскалем, Бейсиком или двумя языками сразу. В анкете 25 человек указали владения Паскалем, А 22 - Бейсиком. Сколько участников программируют только на Паскале?
Ответы (2)
Как обозначается факториал на компьютере? К примеру, корень из х записывается как sqrt (x), квадрат числа пишется как x^2. А как подобным образом записать факториал?
Ответы (1)
Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.
Ответы (2)
Помогите с Паскалем! Найти сумму всех четных трехзначных чисел которые делятся на 7. Написать программу.
Ответы (1)