Задать вопрос
8 декабря, 02:57

Составить программы на языке Турбо Паскаль.

1. Даны N чисел. Найти произведение четных и сумму нечетных.

2. Даны N чисел. Найти количество положительных и количество отричательных. Сравнить результаты.

+5
Ответы (1)
  1. 8 декабря, 04:13
    0
    1) var n, odd, even, i, a: integer;

    begin

    odd:=0;

    even:=1;

    writeln ('Введите число N') ;

    read (N) ;

    writeln ('Введите N целых чисел') ;

    for i:=1 to N do

    begin

    read (a) ;

    if (a mod 2 = 0) then even:=even*a

    else odd:=odd+a;

    end;

    writeln ('Произведение чётных чисел равно ', even) ;

    writeln ('Сумма нечётных чисел равна ', odd) ;

    end.

    2) var N, plus, minus, i: integer;

    a: real;

    begin

    plus:=0;

    minus:=0;

    writeln ('Введите число N') ;

    read (N) ;

    writeln ('Введите N чисел') ;

    for i:=1 to N do

    begin

    read (a) ;

    if (a > 0) then plus:=plus+1;

    if (a < 0) then minus:=minus+1;

    end;

    writeln ('Количество положительных чисел равно ', plus) ;

    writeln ('Количество отрицательных чисел равно ', minus) ;

    if (plus
    if (plus>minus) then writeln ('Положительных больше чем отрицательных на ', plus-minus) ;

    if (plus=minus) then writeln ('Количество положительных равно количеству отрицательных') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программы на языке Турбо Паскаль. 1. Даны N чисел. Найти произведение четных и сумму нечетных. 2. Даны N чисел. Найти количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
1. Что является составляющими языка? а) Синтаксис; б) Семантика; в) Грамматика; г) Морфология. 2. Средой Что есть визуального программирования? а) Турбо Паскаль; б) Турбо в Excel; в) Турбо Дельфи; г) базовые. 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)