Задать вопрос
9 марта, 10:16

4. Массив А размером 10 заполняется по формуле I-4, где I - счётчик индексов. Поменять местами второй и предпоследний элементы массива. (в паскале)

+3
Ответы (1)
  1. 9 марта, 13:08
    0
    Var

    a: array[1 ... 10] of integer;

    i: integer;

    begin

    for i:=1 to 10 do

    a[i] : = i-4;

    a[2] : = a[9] + a[2];

    a[9] : = a[2] - a[9];

    a[2] : = a[2] - a[9];

    for i:=1 to 10 do

    write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «4. Массив А размером 10 заполняется по формуле I-4, где I - счётчик индексов. Поменять местами второй и предпоследний элементы массива. (в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.
Ответы (1)
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)