Задать вопрос
26 сентября, 18:55

Заданы три числа hh, mm, ss. Определите, является ли hh : mm : ss - корректным показанием электронных часов, т. е. число hh должно быть в диапазоне от 0 до 23, числа mm и ss должны быть в диапазоне от 0 до 59.

+1
Ответы (1)
  1. 26 сентября, 21:21
    0
    Var

    hh, mm, ss: integer;

    begin

    readln (hh, mm, ss) ;

    if (hh in [0 ... 23]) and (mm in [0 ... 59]) and (ss in [0 ... 59]) then

    writeln ('Корректно')

    else

    writeln ('Не корректно') ;

    end.

    Либо можно так:

    var

    hh, mm, ss: integer;

    begin

    readln (hh, mm, ss) ;

    if (hh > = 0) and (hh = 0) and (mm = 0) and (ss < = 59) then

    writeln ('Корректно')

    else

    writeln ('Не корректно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заданы три числа hh, mm, ss. Определите, является ли hh : mm : ss - корректным показанием электронных часов, т. е. число hh должно быть в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Операция "логическое и" применяется в сложных условиях, когда 1 все простые условия должны быть истинными 2 все простые условия должны быть ложными 3 хотя бы одно простое условия должно быть ложным 4 хотя бы одно простое условия должно быть истинным
Ответы (1)
Операция "логическое или" применяется в сложных условиях, когда 1. все простые условия должны быть истинными 2. все простые условия должны быть ложными 3. хотя бы одно простое условия должно быть ложным 4.
Ответы (1)
Pascal Вывести для каждого заданного числа количество цифр. Формат ввода: Элементы последовательности (целые числа в диапазоне от - 30000 до 30000) заданы по одному на строке через пробел.
Ответы (1)
Заданы двоичные числа X и Y. Вычислить X+Y и X-Y, если: а) Х = 1101001, Y = 101111; б) Х = 101110110, Y = 10111001 в) Х = 100011001, Y = 101011 Заданы двоичные числа X и Y.
Ответы (1)
Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано".
Ответы (1)