Задать вопрос
1 декабря, 16:36

Pascal Вывести для каждого заданного числа количество цифр.

Формат ввода:

Элементы последовательности (целые числа в диапазоне от - 30000 до 30000) заданы по одному на строке через пробел. Признак окончание последовательности - число 0 (в последовательность не входит).

Формат вывода:

Целое число.

Пример входных данных

1 - 23 - 31 486 0

Пример выходных данных

1223

+4
Ответы (1)
  1. 1 декабря, 18:56
    0
    Var

    i, n, k:longint;

    a:array [1 ... 30000] of longint;

    begin

    n:=0;

    for i:=1 to 30000 do

    begin

    read (a[i]) ;

    if a[i]0

    then n:=n+1

    else break;

    end;

    for i:=1 to n do

    begin

    k:=0;

    while a[i]0 do

    begin

    a[i]:=a[i] div 10;

    k:=k+1;

    end;

    writeln (k,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal Вывести для каждого заданного числа количество цифр. Формат ввода: Элементы последовательности (целые числа в диапазоне от - 30000 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив целых чисел в диапазоне от - 30000 до 30000. Отсортировать его по убыванию. Методом простого выбора. Формат ввода: В первой строке - количество элементов массива не превосходящее 100. На второй строке через пробел элементы массива.
Ответы (1)
Решите на пасхале Задача: Найти количество четных цифр натурального числа. Формат ввода: На вход подается натуральное, не превосходящее 30000. Формат вывода: Целое число. Пример входных данных 321 Пример выходных данных 1
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)