Задать вопрос
15 января, 11:28

1. найти результат вычисления арифметического выражения y=a (x+1), где a=2, x принадлежит [-5; 15] с шагом = 1. вычислить все значения и найти количество элементов <10. (решите через while или repeat)

2. найти площадь кольца, если внутренний радиус которого равен 20, а внешний заданному числу r (r>20).

+5
Ответы (1)
  1. 15 января, 12:23
    0
    Var a, i, k: integer;

    begin

    k:=0;

    a:=2;

    x:=-5;

    while x<=15 do begin

    y:=a * (x+1) ;

    writeln (y) ;

    x:=x+1;

    if y<10 then k:=k+1;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. найти результат вычисления арифметического выражения y=a (x+1), где a=2, x принадлежит [-5; 15] с шагом = 1. вычислить все значения и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
В паскале в 3 циклах: for; repeat; white. Вычислить и напечатать значения функции и соответствующие им значения аргументов x, y. z=2xy-2yx при изменении первого аргумента x[-1; 1] с шагом 0.1 и второго аргумента y[2; 2] с шагом 0.2.
Ответы (1)
Запишите оператор для: а) вычисления среднего арифметического переменных x1 и x2, б) уменьшения на единицу значения переменной k в) увеличение на еденицу значения переменной i г) вычисления стоимости покупки, состоящей из нескольких тетрадей,
Ответы (1)