Задать вопрос
9 марта, 10:57

Написать программу на Паскале

У меня X яблок ... Яблоко стоит E $, курс доллара к рублю p рублей за доллар ... И Y человек ... Сколько нужно яблок чтобы каждому человеку досталось по 1.66 яблока, или больше, количество яблок должно быть кратно 5 (недостающие яблоки можно докупить) и сколько рублей нужно будет потратить

+4
Ответы (1)
  1. 9 марта, 11:30
    0
    Var

    X, Y, K:integer;

    E, p:real;

    Begin

    Write ('Сколько яблок в наличии: ') ; ReadLn (X) ;

    Write ('Сколько человек: ') ; ReadLn (Y) ;

    Write ('Сколько долларов за одно яблоко: ') ; ReadLn (E) ;

    Write ('Сколько рублей за один доллар: ') ; ReadLn (p) ;

    if X mod 5 0 then K:=X+5 - (X mod 5)

    else K:=X;

    While K/Y<1.66 do K:=K+5;

    WriteLn ('Требуемое количество яблок: ', K) ;

    WriteLn ('Столько яблок придётся докупить: ', K-X) ;

    WriteLn ('Стоимость докупленных яблок: ', (K-X) * E*p:0:2,' руб.') ;

    End.

    Пример:

    Сколько яблок в наличии: 1

    Сколько человек: 3

    Сколько долларов за одно яблоко: 50

    Сколько рублей за один доллар: 0.05

    Требуемое количество яблок: 5

    Столько яблок придётся докупить: 4

    Стоимость докупленных яблок: 10.00 руб.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале У меня X яблок ... Яблоко стоит E $, курс доллара к рублю p рублей за доллар ... И Y человек ... Сколько ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу. В одну из школ требуется закупить k карандашей для удобства они продаются в упаковках по 13 карандашей сколько упаковок требуется купить а сколько карандашей нужно будет докупить без упаковки?
Ответы (2)
Гномы нашли яблоко весом 300 грамм. Каждый гном откусывал часть яблока, составляющую 3% от веса имеющегося яблока. Сколько гномов съедят половину яблока? Каков будет вес оставшегося яблока?
Ответы (2)
Составьте программу решения следующей задачи: с первой яблони собрали одно яблоко, со второй 2 яблока, с третьей 3 яблока, с четвертой 4 яблока и т. д. и наконец с 15 - 15 яблок сколько яблок собрали со всех 15 яблонь?
Ответы (1)
Задача на Паскале. Дано число, если оно кратно 3 (трем) - увеличить его на 5, если кратно 2 (двум) - увеличить в 4 раза, если не кратно - увеличить на 1. * Использовать функцию "остаток от деления равен нулю".
Ответы (1)
Язык программирования Паскаль ABC Ввести стоимость товара в долларах в курс доллара по отношению к рублю. Определите стоимость в рублях
Ответы (1)