Задать вопрос
20 декабря, 03:23

На вход даются 2 числа. Далее, выводится меню с перечнем:

1) + '

2) -

3) *

4) /

Программа должна ожидать ввода выбранного пункта, и выполнять соответствующее действие

+3
Ответы (1)
  1. 20 декабря, 06:07
    0
    Const cr=chr (13) + chr (10) ;

    var a, b:integer; c:char;

    begin

    writeln ('Введите 2 числа:') ;

    readln (a, b) ;

    writeln ('Введите операцию:') ;

    writeln ('1) + ', cr,'2) - ', cr,'3) * ', cr,'4) / ') ;

    readln (c) ;

    case c of

    '+': writeln (a,' + ', b,' = ', a+b) ;

    '-': writeln (a,' - ', b,' = ', a-b) ;

    '*': writeln (a,' * ', b,' = ', a*b) ;

    '/': writeln (a,' / ', b,' = ', a/b) ;

    else writeln ('Ошибка ввода') ;

    end;

    end.

    Пример:

    Введите 2 числа:

    5 8

    Введите операцию:

    1) +

    2) -

    3) *

    4) /

    *

    5 * 8 = 40
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На вход даются 2 числа. Далее, выводится меню с перечнем: 1) + ' 2) - 3) * 4) / Программа должна ожидать ввода выбранного пункта, и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В некотором каталоге хранился файл Меню. doc, имевший полное имя F:/Школа/Столовая/Меню. doc. В этом каталоге создали подкаталог Обед и файл Меню. doc переместили в созданный подкаталог. Укажите полное имя этого файла после перемещения.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Нужно написать программу в паскале. На вход поступает некое целое число икс (х). Х принадлежит промежутку (-30000; 30000) Если Х четное и делится на 5 то выводится соответствующая надпись. Если нет - надпись не выводится
Ответы (1)
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)