Задать вопрос
11 июня, 01:11

Напишите программу в PascalABC: нахождение наибольшего целого делителя целого числа

+2
Ответы (1)
  1. 11 июня, 01:22
    0
    Var n, i, d: integer;

    found: boolean;

    begin

    d:=1;

    found:=false;

    writeln ('Введите целое число больше единицы') ;

    readln (n) ;

    if n mod 2 = 0 then d : = n div 2

    else

    begin

    i: = (n div 2) - 1;

    while (found=false) and (i > 2) do

    begin

    if n mod i = 0 then begin found:=true; d:=i; end;

    i:=i-1;

    end;

    end;

    if d=1 then writeln ('введённое число оказалось простым')

    else writeln ('наибольший целый делитель введённого числа равен ', d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в PascalABC: нахождение наибольшего целого делителя целого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите нужно использовать программу PascalABC Вариант 2 Программа PascalABC Кровяное давление у старшеклассников считается нормальным, если верхняя его граница H ≤ 100, а нижняя h ≥ 60 и H-h ≥ 30.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
PascalABC Цена товара обозначена в рублях с точностью до копеек, то есть вещественным числом с двумя цифрами после десятичной точки. В целочисленных переменных получите и выдайте значения целого числа рублей и целого числа копеек в цене товара.
Ответы (1)
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3.
Ответы (1)