Задать вопрос
13 мая, 18:35

Вычислить сумму натуральных чисел от 1 до N.

Составить программу нахождения кол-ва делителей числа N (значение N вводится с клавиатуры)

+1
Ответы (1)
  1. 13 мая, 20:46
    0
    Держи!

    1)

    var i, n, result:integer;

    begin

    read (n) ;

    result:=0;

    for i:=1 to n do

    begin

    result:=result+i;

    end;

    write (result) ;

    end.

    2)

    var i, n, increase, result:integer;

    massive = array[1 ... 1000] of integer; / / ищем делители в диапазоне 1-1000

    begin

    read (n) ;

    for i:=1 to 1000 do

    begin

    if ((n mod massive[i]) = 0) then

    begin

    increase:=increase + 1;

    end;

    end;

    result:=increase;

    write (result) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму натуральных чисел от 1 до N. Составить программу нахождения кол-ва делителей числа N (значение N вводится с клавиатуры) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)