Задать вопрос
25 октября, 14:10

Написать текст программы для решения задачи:

Спросить у пользователя 3-х значное натуральное число и выяснить, является ли средняя цифра в записи числа четной.

Например, для числа 123 средняя цифра 2 - четная.

+2
Ответы (1)
  1. 25 октября, 17:21
    0
    Pascal ABC

    var a, b:integer;

    begin

    write ('Введите 3-значное число:') ;

    readln (a) ;

    b:=a mod 100;

    b:=b div 10;

    if b mod 2=0 then

    writeln (b,' - четное')

    else

    writeln (b,' - нечетное') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать текст программы для решения задачи: Спросить у пользователя 3-х значное натуральное число и выяснить, является ли средняя цифра в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная. Формат ввода В входном файле находится одно четырехзначное число.
Ответы (1)
Разработайте программу, которая просит пользователя ввести с клавиатуры 2 числа. Если сумма чисел четная, следует 2-ое число разделить на 1-ое и вывести результат на экран, если сумма чисел не четная, следует 1-ое число умножить на второе и вывести
Ответы (1)
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа. Формат ввода: в входном файле находится одно четырех значное число.
Ответы (1)