Задать вопрос
8 апреля, 16:50

Определить по координатам трех точек, что они являются вершинами прямоугольного трекгольника.

Pascal

+5
Ответы (1)
  1. 8 апреля, 17:43
    0
    Var

    Ax, Ay, Bx, By, Cx, Cy, AB, BC, CA:real;

    Begin

    WriteLn ('Координаты точки A') ;

    Write (' x = ') ; ReadLn (Ax) ;

    Write (' y = ') ; ReadLn (Ay) ;

    WriteLn ('Координаты точки B') ;

    Write (' x = ') ; ReadLn (Bx) ;

    Write (' y = ') ; ReadLn (By) ;

    WriteLn ('Координаты точки C') ;

    Write (' x = ') ; ReadLn (Cx) ;

    Write (' y = ') ; ReadLn (Cy) ;

    AB:=Sqr (Ax-Bx) + Sqr (Ay-By) ;

    BC:=Sqr (Bx-Cx) + Sqr (By-Cy) ;

    CA:=Sqr (Cx-Ax) + Sqr (Cy-Ay) ;

    if (Sqrt (AB)
    if (AB+BC=CA) or (BC+CA=AB) or (CA+AB=BC) then WriteLn ('Треугольник ABC - прямоугольный')

    else WriteLn ('Треугольник ABC не является прямоугольным')

    else WriteLn ('Данные точки не являются вершинами треугольника')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить по координатам трех точек, что они являются вершинами прямоугольного трекгольника. Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)
Пусть даны координаты трёх точек на плоскости. Если они могут быть вершинами прямоугольного треугольника, вычислите его площадь
Ответы (1)
Напишите функциюS (x1, y1, x2, y2, x3, y3), которая принимает коорди- наты трёх точек на плоскости. Если они могут быть вершинами равно- бедренного прямоугольного треугольника, то функция дает площадь тре- угольника, в противном случае дает - 1.
Ответы (1)