Задать вопрос
29 ноября, 00:18

Напишите программу, которая в последовательности натуральных чисел определяет количество четырёхзначных чисел, кратных 7. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность).

программа должна вывести одно число: количество четырёхзначных чисел, кратных 7.

+2
Ответы (1)
  1. 29 ноября, 00:36
    0
    Var A, k:integer;

    Begin

    k:=0;

    Repeat

    Read (A) ;

    if (A>999) and (A<10000) and (A mod 7 = 0) then k:=k+1;

    Until A = 0;

    Write (k)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности натуральных чисел определяет количество четырёхзначных чисел, кратных 7. программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем. (a=0 признак окончания ввода, ноль не входит в последовательность).
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)