Задать вопрос
11 января, 05:17

Помогите, плесс.

на языке паскаля.

напишите программу, которая в последовательности натуральных чисел определяет минимальное, оканчивающееся на 2. Программа получает числа. Признак окончания ввода 0. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число - минимальное, оканчивающееся на 2, если таких нет, вывести на экран об этом сообщение.

+4
Ответы (1)
  1. 11 января, 05:37
    0
    Var

    A, m:integer;

    Begin

    m:=32767;

    Repeat

    Read (A) ;

    if (A mod 10 = 2) and (A < m) then m:=A;

    Until A=0;

    if m mod 2 = 0 then WriteLn (m)

    else WriteLn ('Чисел, оканчивающихся двойкой нет.')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите, плесс. на языке паскаля. напишите программу, которая в последовательности натуральных чисел определяет минимальное, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)