Задать вопрос
16 мая, 22:47

Дано 6-ти значное число

Найти сумму его цифр

(С помощбя паскаля)

(Информатика 9 класс)

+3
Ответы (1)
  1. 17 мая, 02:15
    0
    Можно так:

    Var

    A, i, S:integer;

    Begin

    WriteLn ('Введите 6-значное число:') ;

    ReadLn (A) ;

    S:=0;

    For i: = 1 to 6 do

    Begin

    S:=S + (A mod 10) ;

    A:=A div 10;

    End;

    WriteLn ('S = ', S)

    End.

    И так:

    Var

    A, S:integer;

    Begin

    WriteLn ('Введите 6-значное число:') ;

    ReadLn (A) ;

    S:=0;

    S:=A mod 10;

    A:=A div 10;

    S:=S + (A mod 10) ;

    A:=A div 10;

    S:=S + (A mod 10) ;

    A:=A div 10;

    S:=S + (A mod 10) ;

    A:=A div 10;

    S:=S + (A mod 10) ;

    A:=A div 10;

    S:=S + (A mod 10) ;

    WriteLn ('S = ', S)

    End.

    Или так

    Var

    A:integer;

    Begin

    WriteLn ('Введите 6-значное число:') ;

    ReadLn (A) ;

    WriteLn ('S = ', (A div 100000) + ((A div 10000) mod 10) + ((A div 1000) mod 10) + ((A div 100) mod 10) + ((A div 10) mod 10) + (A mod 10))

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 6-ти значное число Найти сумму его цифр (С помощбя паскаля) (Информатика 9 класс) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)