Задать вопрос
20 июля, 01:58

Напишите программу. и блок-схему.

Вводится массив из 15 элементов, нужно определить сколько эл. массива будут между его макс и миним. элементом.

+4
Ответы (1)
  1. 20 июля, 05:29
    0
    Uses crt;

    const n = 15;

    var i, imin, imax, m, min, max, j: integer;

    a: array[1 ... n]of integer;

    begin

    Writeln ('Введите числа в массив') ;

    for i : = 1 to n do

    readln (a[i]) ;

    for i : = 1 to n do

    write (a[i], ' ') ;

    min : = a[1];

    max : = a[1];

    imin : = 1;

    imax : = 1;

    for j : = 1 to n do

    begin

    if (a[j] > max) then

    begin

    max : = a[j];

    imax : = j;

    end;

    if (a[j] < min) then

    begin

    min : = a[j];

    imin : = j;

    end;

    end;

    writeln () ;

    writeln ('индекс минимального элемента ', imin, ' индекс максимального элемента ', imax) ;

    m : = abs (imin - imax) ;

    Writeln () ;

    Writeln ('Кол-во элементов между макс. и мин. элементами ', m - 1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу. и блок-схему. Вводится массив из 15 элементов, нужно определить сколько эл. массива будут между его макс и миним. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)