Задать вопрос
20 апреля, 07:33

Помогите написать 2 программы в Pascal ABC

1. дана точка а с координатами x. y, и радиус окружности, центр которой лежит в точке о, как расположится точка и окружность

2. даны координаты вершины треугольника, является ли он прямоугольным

+1
Ответы (1)
  1. 20 апреля, 08:41
    0
    Var Ax, Ay, Ox, Oy, R:real;

    Begin

    WriteLn ('Точка А:') ;

    Write (' x = ') ; ReadLn (Ax) ;

    Write (' y = ') ; ReadLn (Ay) ;

    WriteLn ('Центр окружности:') ;

    Write (' x = ') ; ReadLn (Ox) ;

    Write (' y = ') ; ReadLn (Oy) ;

    Write ('Радиус окружности: ') ; ReadLn (R) ;

    if sqr (Ax-Ox) + Sqr (Ay-Oy) < R*R then WriteLn ('Точка лежит внутри окружности')

    else if sqr (Ax-Ox) + Sqr (Ay-Oy) = R*R then WriteLn ('Точка лежит на окружности')

    else WriteLn ('Точка находится вне окружности')

    End.

    Var

    Ax, Ay, Bx, By, Cx, Cy, AB, BC, CA:real;

    Begin

    WriteLn ('Координаты первой вершины') ;

    Write (' x = ') ; ReadLn (Ax) ;

    Write (' y = ') ; ReadLn (Ay) ;

    WriteLn ('Координаты второй вершины') ;

    Write (' x = ') ; ReadLn (Bx) ;

    Write (' y = ') ; ReadLn (By) ;

    WriteLn ('Координаты третьей вершины') ;

    Write (' x = ') ; ReadLn (Cx) ;

    Write (' y = ') ; ReadLn (Cy) ;

    AB:=Sqr (Ax-Bx) + Sqr (Ay-By) ;

    BC:=Sqr (Bx-Cx) + Sqr (By-Cy) ;

    CA:=Sqr (Cx-Ax) + Sqr (Cy-Ay) ;

    if (AB+BC=CA) or (BC+CA=AB) or (CA+AB=BC) then WriteLn ('Треугольник - прямоугольный')

    else WriteLn ('Данный треугольник не является прямоугольным')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать 2 программы в Pascal ABC 1. дана точка а с координатами x. y, и радиус окружности, центр которой лежит в точке о, как ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) PS: Pascal (не турбо) Всем буду
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Ответы (1)