Задать вопрос
30 июля, 00:41

Даны четыре числа. Для каждого числа найти все его делители и подсчитать их количество Pascal

+5
Ответы (2)
  1. 30 июля, 03:49
    0
    Var

    i: integer;

    ar: array[1 ... 4]of integer;

    procedure Divisor (x: integer) ;

    var

    d, c: integer;

    begin

    c : = 1;

    if (x < 1) then exit;

    write (x, ' = ') ;

    if (x = 1) then begin writeln (1, ' Количество делителей:', 1) ; exit end;

    d : = 2;

    while x > 1 do

    begin

    if (x mod d = 0) then

    begin

    if (x div d 1) then write (d, ' * ')

    else write (d, '; ', ' Количество делителей:', c) ;

    x : = x div d;

    c : = c + 1;

    end

    else d : = d + 1;

    end;

    writeln;

    end;

    begin

    writeln ('Введите четыре числа:') ;

    for i : = 1 to 4 do read (ar[i]) ;

    writeln;

    for i : = 1 to 4 do Divisor (ar[i]) ;

    end.
  2. 30 июля, 03:59
    0
    Var

    A, d, k, i:longint;

    Begin

    WriteLn ('Введите четыре числа') ;

    For i: = 1 to 4 do

    Begin

    Read (A) ;

    Write ('Делители числа ', A,': ', A,', ') ;

    d:=A div 2+1;

    While d>0 do

    Begin

    if A mod d = 0 then

    Begin

    Write (d,', ') ;

    k:=k+1;

    End;

    d:=d-1;

    End;

    Write ('кол-во его делителей: ', k) ;

    k:=1;

    WriteLn;

    End;

    End.

    Пример:

    Введите четыре числа

    987654321 32767 256 13

    Делители числа 987654321: 987654321, 329218107, 109739369, 58097313, 19365771, 6455257, 3417489, 1139163, 379721, 2601, 867, 289, 153, 51, 17, 9, 3, 1, кол-во его делителей: 17

    Делители числа 32767: 32767, 4681, 1057, 217, 151, 31, 7, 1, кол-во его делителей: 8

    Делители числа 256: 256, 128, 64, 32, 16, 8, 4, 2, 1, кол-во его делителей: 9

    Делители числа 13: 13, 1, кол-во его делителей: 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны четыре числа. Для каждого числа найти все его делители и подсчитать их количество Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Два множества: первое все простые делители некоторого целого числа N и второе все простые делители того же числа. Вывести на экран делители которые не являются простыми. (Паскаль)
Ответы (1)
1) В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3. 2) В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.
Ответы (1)