Задать вопрос
20 января, 19:21

1) В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.

2) В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.

+4
Ответы (1)
  1. 20 января, 19:33
    0
    var i, i1, i2, count1, count2:integer;

    begin

    count1:=0;

    count2:=0;

    for i:=0 to 100 do

    if (i mod 10=3) then inc (count1) ;

    for i:=0 to 50 do

    begin

    i1:=i mod 10;

    i2:=i div 10;

    if (i1+i2=3) then inc (count2) ;

    end;

    writeln (count1) ;

    writeln (count2) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3. 2) В диапазоне от 0 до 50 подсчитать количество чисел сумма ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1. напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Прога, которая определяет количество чисел, оканчивающихся на 5, прога получает на вход кол во чисел, а затем сами числа, программа должна вывести одно число-количество чисел оканчивающихся на 5
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Получить все шестизначные числа, в диапазоне от 0 до 999999, у которых сумма первых трех цифр равна сумме последних трех цифр. Если в числе меньше шести цифр, то оно слева дополняется нулями.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)