Задать вопрос
19 марта, 23:13

Дан целочисленный массив на n элементов, вывести на экран элементы у которых остаток k от деления на число x лежит в диапазоне от 0 до - 1

+3
Ответы (1)
  1. 19 марта, 23:35
    0
    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, x:integer;

    Begin

    Write ('x = ') ;

    ReadLn (x) ;

    Write ('Исходный массив: ') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (N) - N div 2;

    Write (A[i],' ') ;

    End;

    WriteLn;

    Write ('Искомые элементы: ') ;

    For i: = 1 to N do

    if (-1 < = A[i] mod x) and (A[i] mod x < = 0) then Write (A[i],' ')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив на n элементов, вывести на экран элементы у которых остаток k от деления на число x лежит в диапазоне от 0 до - 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)