Задать вопрос
21 апреля, 08:39

Дан массив указать наименьшую длину числовой оси содержащую все числа массива

+3
Ответы (1)
  1. 21 апреля, 11:24
    0
    Const N = 13;

    Var

    A:array[1 ... N] of integer;

    i, Min, Max:integer;

    Begin

    For i: = 1 to N do

    Begin

    A[i]:=random (N) ;

    Write (A[i],' ')

    End;

    Max:=A[1];

    Min:=A[1];

    For i: = 2 to N do

    Begin

    if Max
    if Min>A[i] then Min:=A[i];

    End;

    WriteLn (' - данные числа лежат на отрезке, длина которого: ', Max - Min) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив указать наименьшую длину числовой оси содержащую все числа массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)