Задать вопрос
13 января, 18:26

С клавиатуры вводятся целые числа. Количество чисел неизвестно, признак окончания ввода 0. Напишите программу, которая вычисляет произведение чисел, которые оканчиваются на 7 и меньше 70.

+5
Ответы (1)
  1. 13 января, 22:24
    0
    Var

    A:integer;

    P:real;

    Begin

    P:=1;

    Repeat

    Read (A) ;

    if (A<70) and (A mod 10 = 7) then P:=P*A;

    Until A = 0;

    WriteLn ('P = ', P) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся целые числа. Количество чисел неизвестно, признак окончания ввода 0. Напишите программу, которая вычисляет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводятся целые числа. Окончание ввода - число ноль. Ноль используется только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру "5".
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)