Задать вопрос
30 ноября, 15:29

Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный элемент кратный 9.

+4
Ответы (1)
  1. 30 ноября, 18:33
    0
    Const

    N = 30;

    Var

    A:array[1 ... N] of byte;

    i, Max:integer;

    Begin

    Max:=0;

    For i: = 1 to N do

    Begin

    A[i]:=random (101) ;

    if (A[i] mod 9 = 0) and (A[i] > Max) then Max:=A[i];

    Write (A[i],' ') ;

    End;

    WriteLn;

    if Max = 0 then WriteLn ('В массиве нет элементов, кратных 9')

    else WriteLn ('Max = ', Max)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный элемент кратный 9. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)