Задать вопрос
13 января, 15:51

Паскаль!

Дан массив A (n). Определите количество четных элементов с четными индексами, кратных 7. Выведите на экран исходный массив и полученное количество.

+4
Ответы (1)
  1. 13 января, 19:42
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, k:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (51) ;

    write (a[i]:4) ;

    end;

    writeln;

    k:=0;

    for i:=1 to n do

    if (a[i] mod 2=0) and (a[i] mod 7=0) and (i mod 2=0) then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Массив A:

    25 29 13 39 9 14 27 16 12 45

    k = 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! Дан массив A (n). Определите количество четных элементов с четными индексами, кратных 7. Выведите на экран исходный массив и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)