Задать вопрос
10 мая, 09:31

Посчитать количество четных чисел в промежутке от n до 100. С помощью програмированния на языке Pascal

+2
Ответы (1)
  1. 10 мая, 11:03
    0
    Var

    n:integer;

    begin

    Write ('n = ') ; ReadLn (n) ;

    if n mod 2 = 0 then Write ((Abs (n-100) + 1) div 2+1)

    else Write (Abs (n-100) div 2+1)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Посчитать количество четных чисел в промежутке от n до 100. С помощью програмированния на языке Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Помогите с информатикой работа с Pascal. Посчитать количество четных чисел в промежутке от 1 до n
Ответы (1)
Напишите программу для Pascal 1) Пользователь вводит число, количество цифр в нем неизвестно, но последняя цифра = 0. Посчитать количество четных положительных цифр в этом числе.
Ответы (1)
Напишите программу, которая для последовательности целых чисел определяет количество четных чисел. Программа получает на вход количество чисел в последоввтельности, а затем сами числа. Количество чисел не привышает 1000.
Ответы (1)