Задать вопрос
10 мая, 09:14

Составить программу формирования массива из 50 элементов, в которой используется признак Р, в зависимости от значения которого реализовывался бы один из способов задания массива: при Р = - 1 с помощью генератора случайных чисел, при Р=0 с помощью формулы А[i] = i + 101, при Р=1 с клавиатуры. Сделать вывод сформированного массива на экран.

+4
Ответы (1)
  1. 10 мая, 13:08
    0
    Const n=50;

    var a: array[1 ... n] of integer;

    p, i: integer;

    begin

    write ('p (-1,0,1) = ') ;

    readln (p) ;

    case p of

    1: for i:=1 to n do a[i]:=random (100) ;

    0: for i:=1 to n do a[i]:=i+101;

    -1: begin for i:=1 to n do read (a[i]) ; readln; end;

    end;

    writeln;

    writeln ('Исходный массив:') ;

    for i:=1 to n do write (a[i],' ') ;

    writeln;

    end.

    Пример (для n=5) :

    p (-1,0,1) = 0

    Исходный массив:

    102 103 104 105 106
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу формирования массива из 50 элементов, в которой используется признак Р, в зависимости от значения которого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1. Создать массив из 20-ти случайных чисел (значения от 0 до 100). Вывести на экран значения массива строкой. Вычислить сумму элементов массива! 2. Создать массив из 20-ти случайных чисел (значения от 0 до 100).
Ответы (1)