Задать вопрос
3 августа, 08:07

Написать программу, подсчитывающую среднее геометрическое всех элементов массива [1 ... 5]

+3
Ответы (1)
  1. 3 августа, 10:39
    0
    Const

    N = 5;

    Var

    A:array[1 ... N] of integer;

    i:integer;

    P:real;

    Begin

    Randomize;

    P:=1;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (N*2+1) ;

    Write (' ', A[i]) ;

    P:=P*A[i];

    End;

    WriteLn;

    WriteLn ('Среднее геометрическое его элементов: ', Power (P, 1/N) : 0:3) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, подсчитывающую среднее геометрическое всех элементов массива [1 ... 5] ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить алгоритм и программу подсчитывающую сумму больших чем соседних элементов массива J из 22 чисел. Значения элементов массива рассчитать по формуле tgB, где B номер элемента массива.
Ответы (1)