Задать вопрос
10 августа, 23:46

Pascal.

1) Удалить из строки все символы пробела.

2) После каждого символа точки добавить пробел.

+3
Ответы (1)
  1. 11 августа, 01:48
    0
    Var s, s1, s2:string; i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    s1:=s;

    while pos (' ', s1) >0 do delete (s1, pos (' ', s1),1) ;

    writeln ('Строка без пробелов:') ;

    writeln (s1) ;

    s2:='';

    for i:=1 to length (s1) do

    if s1[i]='.' then s2:=s2+'. ' else s2:=s2+s1[i];

    writeln ('Строка с пробелами после ".":') ;

    writeln (s2) ;

    end.

    Пример:

    Введите строку:

    1. 2. 3. 4. 5. Вышел зайчик. Погулять.

    Строка без пробелов:

    1.2.3.4.5. Вышелзайчик. Погулять.

    Строка с пробелами после ".":

    1. 2. 3. 4. 5. Вышелзайчик. Погулять.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. 1) Удалить из строки все символы пробела. 2) После каждого символа точки добавить пробел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)
1. Из слова "пробел" путём замены его букв получить слово "продел" 2. В данной строк вставить пробел после каждого символа. 3. Дано слово. Определить, одинаковы ли в нём второй и четвёртый символы.
Ответы (1)
Pascal, записи Удалить все символы "+", а символы, не являющиеся "+", удвоить
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)