Задать вопрос
12 июля, 07:53

Дано число, определить является оно простым или нет, Вывести "yes" или "no".

Сделать на Free Pascal.

+4
Ответы (1)
  1. 12 июля, 08:22
    0
    Program n1;

    var n: integer;

    function pr (a: integer) : boolean;

    var i: integer;

    begin

    if a<2 then pr:=false

    else begin

    pr:=true;

    for i:=2 to round (sqrt (a)) do

    if a mod i=0 then pr:=false;

    end;

    end;

    begin

    readln (n) ;

    if pr (n) then write ('yes')

    else write ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано число, определить является оно простым или нет, Вывести "yes" или "no". Сделать на Free Pascal. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Помогите, прошу! Программирование на языке Pascal, используя Case Ввести число (от 1 до 4) если число = 1 то вывести окружность, если - 2, то вывести квадрат, если - 3, вывести ромб, если - 4, вывести параллелограмм.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)