Задать вопрос
11 февраля, 14:01

Найти произведение всех натуральных чисел от 1 до 100 на языке pascal

+5
Ответы (1)
  1. 11 февраля, 14:20
    0
    На турбо паскале невозможно сделать этого, т. к. идет переполнение возможного лимита данных (real, longint). В идеале это должно выглядеть так:

    var

    a:real;

    i:byte;

    begin

    a:=1;

    for i:=1 to 100 do begin

    a:=a*i;

    end;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти произведение всех натуральных чисел от 1 до 100 на языке pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Вася изучал сегодня на информатике тему "Рекурсия". После урока на доске осталась такая функция (для условия на языке Pascal - процедура) : на языке Python: def f (n) : print ('*') if n > 2: f (n - 1) f (n - 2) на языке Pascal: procedure f (n:
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
1 вариант. 1. Найти сумму и произведение первых 6 последовательных натуральных чисел. 2. Найти сумму первых k последовательных нечетных чисел. 3. Вывести на экран натуральные нечётные числа от 5 до 55. 4.
Ответы (1)