Задать вопрос
16 июня, 22:11

Составить программу в паскале. Переставить элементы одномерного массива по следующей схеме: а) исходный массив - а[1], а[2], а[3], а[4], а[5]. б) итоговый - а[5], а[4], а[3], а[2], а[1].

+4
Ответы (1)
  1. 17 июня, 00:13
    0
    Uses Crt;

    Const

    N = 5;

    Var

    A:array[1 ... N] of integer;

    i, B:integer;

    Begin

    ClrScr;

    Randomize;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (2*N+1) ;

    Write (' ', A[i]) ;

    End;

    WriteLn;

    Write ('Итоговый массив:') ;

    For i: = 1 to N div 2 do

    Begin

    B:=A[N-i+1];

    A[N-i+1]:=A[i];

    A[i]:=B

    End;

    For i: = 1 to N do

    Write (' ', A[i]) ;

    ReadLn

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале. Переставить элементы одномерного массива по следующей схеме: а) исходный массив - а[1], а[2], а[3], а[4], ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)