Задать вопрос
16 сентября, 23:50

Написать программу на Паскале:

На вход подаются целые числа до появления нуля. Вывести максимальное количес тво подряд идущих чисел, кратных 3.

+4
Ответы (1)
  1. 16 сентября, 23:57
    0
    Var

    x, n, max: integer;

    begin

    n : = 0;

    max : = 0;

    while true do

    begin

    read (x) ;

    if (x mod 3 = 0) and (x0) then n : = n + 1

    else begin if (n > max) then max : = n; n : = 0; end;

    if (x = 0) then break;

    end;

    write (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале: На вход подаются целые числа до появления нуля. Вывести максимальное количес тво подряд идущих чисел, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)