Задать вопрос
4 января, 17:40

В целочисленном массиве каждый элемент, кратный 4, заменить на 0

+1
Ответы (1)
  1. 4 января, 20:08
    0
    Var

    a: array[1 ... 100] of integer;

    i, n: integer;

    begin

    n : = 50;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    a[i] : = random (60) ;

    write (a[i], ' ') ;

    end;

    writeln () ;

    {изменение элементов}

    writeln ('Новые значения:') ;

    for i : = 1 to n do

    begin

    if a[i] mod 4 = 0 then

    a[i] : = 0;

    write (a[i], ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В целочисленном массиве каждый элемент, кратный 4, заменить на 0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)
1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.
Ответы (1)
В одномерном целочисленном массиве посчитать кол-во единиц. Заменить на 0 все четные элементы. Определить мин. Элемент и его номер.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
В целочисленном массиве A 20 случайных чисел из интервала от - 10 до 15. Подсчитать количество отрицательных чисел в этом массиве
Ответы (1)