Задать вопрос
28 октября, 00:58

Программа получает на вход целые числа, не равные 0. Количество введенных чисел неизвестно, последовательность чисел заканчивается 0. Введенные числа по модулю не превышают 30000. Программа должна ответить на вопрос: верно ли, что максимальное из чисел превышает минимальное больше чем в 2 раза?

+5
Ответы (1)
  1. 28 октября, 02:14
    0
    Var A, Max, Min:integer;

    Begin

    ReadLn (A) ;

    Max:=A;

    Min:=A;

    While A0 do

    Begin

    ReadLn (A) ;

    if A>Max then Max:=A;

    if A
    End;

    WriteLn (Max/Min > 2)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа получает на вход целые числа, не равные 0. Количество введенных чисел неизвестно, последовательность чисел заканчивается 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)