Задать вопрос
24 июля, 13:09

Паскаль

Входной файл содержит данные о пользователях социальных сетей в виде:

Иванов Иван М 42

Петрова Анна Ж 26

Вывести в выходной файл фамилии и имена всех мужчин младше 30 лет.

+2
Ответы (1)
  1. 24 июля, 16:38
    0
    Var vz: integer;

    fin, fout: text;

    st: string;

    begin

    assign (fin,'data. in') ;

    reset (fin) ;

    assign (fout,'data. out') ;

    rewrite (fout) ;

    while not eof (fin) do

    begin

    readln (fin, st) ;

    vz:=StrToInt (Copy (st, length (st) - 1,2)) ;

    if (vz<30) and (st[length (st) - 3]='М') then

    writeln (fout, Copy (st, 1, length (st) - 5)) ;

    end;

    close (fin) ;

    close (fout) ;

    end.

    { data. in

    Иванов Иван М 26

    Перова Марья Ж 21

    Петров Василий М 32

    Сидоров Андрей М 18

    data. out

    Иванов Иван

    Сидоров Андрей

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Входной файл содержит данные о пользователях социальных сетей в виде: Иванов Иван М 42 Петрова Анна Ж 26 Вывести в выходной файл ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача: написать программу на Паскале, С (С++) или Бейсике. Входной файл: input. txt. Выходной файл: output. txt. Ограничение времени выполнения программы: 1 секунда на тест.
Ответы (1)
Турбо Паскаль. Написать программу, которая считает количество буквы в строке. Допустим букву "а" в любом регистре, строка вводится с клавиатуры. входной файл: предложение выходной файл: количество буквы
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Написать программу, вычисляющую произведение цифр в сумме трех целых числа A, B И C. Входной файл В единственной строке файла содержатся три целых числа A, B И C, разделенных пробелами.
Ответы (1)