Задать вопрос
31 июля, 11:28

Составьте программу в паскаль с помощью while. Стакан кипятка (100 °С) остыл за первую минуту на А градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. Через сколько минут температура воды станет ниже Nо С?

+3
Ответы (1)
  1. 31 июля, 13:53
    0
    Var A, gradus, minut, N: real;

    Begin

    Writeln ('Введите A градусов') ;

    readln (A) ;

    Writeln ('До какой температуры остужать:') ;

    readln (N) ;

    gradus:=100-A; minut:=1;

    While (gradus>N) do

    Begin

    A:=A * (1-0.15) ;

    gradus:=gradus-A;

    minut:=minut+1;

    end;

    Writeln ('Кипяток остынет до ', N,' градусов через ', minut, ' минут') ;

    readln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в паскаль с помощью while. Стакан кипятка (100 °С) остыл за первую минуту на А градусов, а каждую последующую минуту ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1) написать программу На столе стоит 10 кастрюль, которые необходимо заполнить водой. В первую кастрюлю помещается 0,5 литра воды, а в каждую следующую на 0,5 литра больше, чем в предыдущую. Сколько воды потребуется для заполнения всех кастрюль?
Ответы (1)
Переделать задачи для for 1) q:=5; d:=1; while q>0 do begin d:=d+q; dec (q) end; writeln (q,' ', d) ; 2) q:=5; d:=1; while q>0 do begin dec (q) ; d:=d+q end; writeln (q,' ', d) ; 3) q:=5; d:=1; while q>0 do dec (q) ; d:=d+q; writeln (q,' ', d) ;
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)