Задать вопрос
7 сентября, 13:36

Транспонировать массив А размером 4 х4 элементов. Вывести на экран исходный и полученный массив.

+3
Ответы (1)
  1. 7 сентября, 16:43
    0
    Const n = 4;

    m = 4;

    var i, j, k: integer;

    a: array [1 ... n, 1 ... m] of integer;

    begin

    randomize;

    for i:=1 to n do begin

    for j:=1 to m do begin

    a[i, j]:=random (10) ;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    for i:=1 to n do

    for j:=i+1 to m do

    begin

    k:=a[i, j];

    a[i, j]:=a[j, i];

    a[j, i]:=k;

    end;

    writeln;

    for i:=1 to n do begin

    for j:=1 to m do

    write (a[i, j]:3) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Транспонировать массив А размером 4 х4 элементов. Вывести на экран исходный и полученный массив. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив.
Ответы (1)