Задать вопрос
8 июля, 19:15

Помогите решить задачу в Delhi.

Дано трехзначное число, в котором все цифры различны. Получить шесть чисел, образованных при перестановке цифр заданного числа.

+5
Ответы (1)
  1. 8 июля, 22:48
    0
    Var a, a1, a2, a3:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a1:=a div 100;

    a2:=a div 10 mod 10;

    a3:=a mod 10;

    writeln (a,' ', a1*100+a3*10+a2) ;

    writeln (a2*100+a1*10+a3,' ', a2*100+a3*10+a1) ;

    writeln (a3*100+a1*10+a2,' ', a3*100+a2*10+a1) ;

    end.

    Пример:

    a = 251

    251 215

    521 512

    125 152
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу в Delhi. Дано трехзначное число, в котором все цифры различны. Получить шесть чисел, образованных при перестановке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача по программированию 8 класс. Решите как положено через паскаль! Дано трехзначное число, в котором все цифры различны. Получить шесть чисел, образованных при перестановке цифр заданного числа.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Дано четырёхзначное число. Получить число, образуемое при перестановке двух первых и двух последних цифр заданного числа. Например, из числа 4567 получить 6745. Мне нужна программа в Pascal!
Ответы (1)
Помогите составить программу. Дано трехзначное число. Найти число, полученное при перестановке второй и третьей цифр заданного числа. (На паскале.)
Ответы (1)
Задача по программированию 8 класс. Решите как положено через паскаль! Дано трехзначное число. Найти число, полученное при перестановке первой и второй цифр заданного числа
Ответы (1)