Задать вопрос
2 марта, 03:51

Написать программу, ожидающую от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет

+3
Ответы (1)
  1. 2 марта, 06:35
    0
    В григорианском календаре високосным является:

    - год, номер которого делится нацело на 400

    - год, номер которого делится на 4, но не делится на 100

    Программа на паскале:

    var n: integer;

    begin

    read (n) ;

    if (n mod 400 = 0) or (n mod 4 = 0) and (n mod 100 > 0)

    then writeln (n, ' год високосный')

    else writeln (n, ' год невисокосный') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, ожидающую от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Разработайте программу, запрашивающую у пользователя длины обеих катетов прямоугольного треугольника, и выводящую на экран гипотезу по формуле Пифагора 2) Запросите у пользователя длину ребра куба, Найдите и выведите на экран площадь одной грани,
Ответы (1)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
Определить количество дней в году, которое вводится пользователем. Алгоритм решения задачи: В високосном году - 366 дней, в обычном 365. Високосными годами являются все года.
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
Какой тип подходит для хранения данных: 1) Фамилия пользователя 2) Наличие судимости у кандидата в депутаты 3) Шестнадцатеричная цифра (0 - F) 4) Цена бублика 5) Площадь треугольника 6) Год рождения пользователя 7) Количество жён в гареме султана
Ответы (1)