Задать вопрос
21 апреля, 11:17

Pascal ABC. Написать программу которая определяет знак зодиака при вводе даты рождения (с использованием case).

+1
Ответы (1)
  1. 21 апреля, 14:05
    0
    Var n, d:integer;

    begin

    write ('Введите месяц : ') ;

    readln (n) ;

    write ('Введите день : ') ;

    readln (d) ;

    n:=n mod 12;

    case n mod 12 of

    1: if d<=20 then writeln ('Козерок') else writeln ('Водолей') ;

    2: if d<=21 then writeln ('Водолей') else writeln ('рыба') ;

    3: if d<=21 then writeln ('рыба') else writeln ('овен') ;

    4: if d<=21 then writeln ('овен') else writeln ('телец') ;

    5: if d<=21 then writeln ('телец') else writeln ('близницы') ;

    6: if d<=22 then writeln ('близницы') else writeln ('рак') ;

    7: if d<=23 then writeln ('рак') else writeln ('лев') ;

    8: if d<=24 then writeln ('лев') else writeln ('дева') ;

    9: if d<=24 then writeln ('дева') else writeln ('весы') ;

    10: if d<=24 then writeln ('весы') else writeln ('скорпион') ;

    11: if d<=23 then writeln ('скорпион') else writeln ('стрелец') ;

    12: if d<=22 then writeln ('стрелец') else writeln ('козерок') ;

    end;

    end.

    //без if вряд ли удаться обойтись (+ я не учитывал високосный год и кратный 100 и 400)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC. Написать программу которая определяет знак зодиака при вводе даты рождения (с использованием case). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)