Задать вопрос
6 марта, 04:43

Задача для языка Free Pascal:

Вычислить значение суммы ряда Y (X) в произвольной точке х, если

Y (x) = sinx + sin^2 (x) + sin^3 (x) + ... + sin^n (x)

Величину х вводить

Выполнить вычисления для 5,10,15 и 20 слагаемых

+5
Ответы (1)
  1. 6 марта, 04:58
    0
    var x, y, p:real; n, i:integer;

    begin

    write ('x = ') ;

    readln (x) ;

    write ('n = ') ;

    readln (n) ;

    p:=1;

    for i:=1 to n do

    begin

    p:=p*sin (x) ;

    y:=y+p;

    end;

    writeln ('y = ', y:6:4) ;

    end.

    Пример:

    x = 1.5

    n = 5

    y = 4.9626
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача для языка Free Pascal: Вычислить значение суммы ряда Y (X) в произвольной точке х, если Y (x) = sinx + sin^2 (x) + sin^3 (x) + ... + ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача для языка Free Pascal Описать функцию S (x, eps), вычисляющую значение суммы ряда в точке с указанной точностью eps, если формула суммы: S = x - x/2 + x/3 - x/4 + x/5 - ...
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)