Задать вопрос
28 февраля, 06:59

Задача для языка Free Pascal

Описать функцию S (x, eps), вычисляющую значение суммы ряда в точке с указанной точностью eps, если формула суммы:

S = x - x/2 + x/3 - x/4 + x/5 - ..., ряд знакопеременный

Обратиться с координатами точек x = [-0,5; 0,5], шаг = 0,1

+1
Ответы (1)
  1. 28 февраля, 09:24
    0
    Function F (x, eps:double) : double;

    var

    s0, s1, sgn, d:real;

    begin

    s1:=x; d:=1; sgn:=1;

    repeat

    s0:=s1; d:=d+1; sgn:=-sgn;

    s1:=s0+sgn*x/d

    until abs (s1-s0) <=eps;

    f:=s1

    end;

    var

    x:double;

    begin

    x:=-0.5;

    while x<=0.5 do begin

    Writeln (x:4:1, F (x, 1e-7) : 14:7) ;

    x:=x+0.1

    end

    end.

    Результат

    -0.5 - 0.3465736

    -0.4 - 0.2772589

    -0.3 - 0.2079442

    -0.2 - 0.1386295

    -0.1 - 0.0693148

    0.0 0.0000000

    0.1 0.0693148

    0.2 0.1386295

    0.3 0.2079442

    0.4 0.2772589

    0.5 0.3465736
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача для языка Free Pascal Описать функцию S (x, eps), вычисляющую значение суммы ряда в точке с указанной точностью eps, если формула ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Program2. pas (29) : Нельзя преобразовать тип function (x: real; eps: real) : real к real var a, i, s, r, j, t, x, eps: real; function v (x, eps: real) : real; begin i : = 1; s : = 0; a : = 1; t : = 1; r : = 1;
Ответы (1)
Лёгкая программа на Pascal Методика выполнения работы Pascal Program lab_4; Uses crt; Var s, eps, x, un, uk, y: real; i: integer; begin clrscr; x:=5; eps:=1e-5; s:=1; i:=1; y:=-1*2; un: = (ln (x) / ln (10)) / y; while abs (un) >eps Do begin s:=s+un;
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Задача для языка Free Pascal: Вычислить значение суммы ряда Y (X) в произвольной точке х, если Y (x) = sinx + sin^2 (x) + sin^3 (x) + ... + sin^n (x) Величину х вводить Выполнить вычисления для 5,10,15 и 20 слагаемых
Ответы (1)