Задать вопрос
11 апреля, 14:45

В однородном массиве найдите произведение ненулевых элементов

+2
Ответы (1)
  1. 11 апреля, 16:42
    0
    Program n1;

    const n=10;

    var a: array [1 ... n] of integer;

    i, p: integer;

    begin

    p:=1;

    for i:=1 to n do readln (a[i]) ;

    for i:=1 to n do if a[i]0 then p:=p*a[i];

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В однородном массиве найдите произведение ненулевых элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В однородном массиве А из n элементов найти количество ненулевых элементов и уменьшить положительные элементы на 20.
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)
В массиве ненулевых целых чисел определить сколько раз элементы массива при просмотре от его начала меняют знак. Например, в массиве 10, - 4, 12, 56, - 4, - 89 знак меняется 3 раза.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
В одномерном массиве найти произведение ненулевых элементов (Задать рандомно)
Ответы (1)