Задать вопрос
1 февраля, 20:55

В массиве ненулевых целых чисел определить сколько раз элементы массива при просмотре от его начала меняют знак. Например, в массиве 10, - 4, 12, 56, - 4, - 89 знак меняется 3 раза. Реализовать ввод размерности и возможность инициализации элементов массива.

+2
Ответы (1)
  1. 1 февраля, 21:24
    0
    Program n1;

    type z = array of integer;

    var a: z;

    i, n, k: longint;

    begin

    writeln ('введите кол-во элементов в массиве: ') ;

    readln (n) ;

    setlength (a, n) ;

    writeln ('введите массив:') ;

    for i:=0 to n-1 do readln (a[i]) ;

    k:=0;

    for i:=1 to n-1 do

    if a[i]*a[i-1]<0 then k:=k+1;

    writeln ('количество ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве ненулевых целых чисел определить сколько раз элементы массива при просмотре от его начала меняют знак. Например, в массиве 10, - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Если список инициализации короче, чем длина объявленного массива, то: 1) Массив укорачивается, согласно списку инициализации 2) Правильных утверждений нет 3) Значения оставшихся элементов не определены 4) Значения оставшихся элементов равны нулю 5)
Ответы (2)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Организовать ввод чисел в массив E состоящий из 7 элементов ввод с клавиатуры сформировать новый массив К состоящий из элементов которые равны квадратам элементов массива Е вывести элементы массива Е найти и вывести номер минимального элемента
Ответы (1)